Cómo instalar la última versión de Spotify en openSUSE

En una de mis recientes instalaciones de openSUSE Leap 42.1, la que fue resultado de un experimento para usar la distribución como único sistema en mi equipo de sobremesa, descubrí que solamente había echado en falta el poder disponer de la aplicación de escritorio de Spotify. A estas alturas pocas personas habrá que no conozcan esta popular solución para escuchar música de una inmensa biblioteca discográfica a cambio de soportar algún que otro anuncio cada cierto tiempo, algo que se puede evitar con una suscripción Premium. Yo soy un usuario habitual, tanto en el ordenador como en el móvil cuando salgo a correr.

En openSUSE encontré ciertas dificultades. Instalada desde el repositorio de Packman, la aplicación no arrancaba y lanzaba un lacónico mensaje de “Tubería rota”. Horas y horas de investigación al respecto – sí, otra vez más es la única forma – me llevaron a dar con la clave para su correcta instalación en la distro del Geeko. Sin embargo, recientemente me topé con un script que lo simplifica todo al máximo. Por si no sois tan afortunados como yo o, en el mejor de los casos, para evitaros la ardua tarea de búsqueda de una solución, os cuento cómo disponer de la versión más actualizada posible de Spotify. Es válido tanto para openSUSE Tumbleweed – según el autor – como para Leap 42.1 – de esto doy fe porque lo estoy disfrutando yo mismo.

El proceso es bien simple. Nos vamos al repositorio en GitHub del autor del script y descargamos el archivo comprimido que lo contiene, pulsando sobre el botón verde de “Clone or download” y luego en el azul de “Download ZIP”.

 

Script instalación Spotify openSUSE
Desde aquí podemos descargar el script de instalación

 

Habremos bajado así el archivo comprimido a nuestro equipo. Lo siguiente será descomprimirlo, algo que es tan fácil como hacer clic con el botón derecho en el administrador de archivos y escoger la opción “Extraer”. Yo uso Dolphin en KDE pero el proceso no difiere demasiado para Archivos de Gnome o Thunar de XFCE.

 

Descomprimir archivo Dolphin
Procedimiento para descomprimir el archivo recibido en Dolphin

 

Una vez extraído el contenido, vamos a abrir una terminal – ¿quién dijo miedo? ¡Es muy fácil! – cosa también harto simple en Dolphin: “Abrir terminal aquí”.

 

Abrir terminal openSUSE
A continuación abrimos un terminal en el directorio donde está el script

 

Lo siguiente ya es el paso definitivo para la instalación, tecleando como un usuario normal (no como root) la siguiente instrucción:

$ ./install-spotify.sh

 

El script descargará desde los servidores de Spotify la última versión disponible en formato “.deb” (paquetería de Debian y derivadas), hará las pertinentes transformaciones a “rpm” (paquetería de RHEL y SUSE, entre otras) y, tras preguntarnos la contraseña de administrador, procederá a instalar el programa en nuestro sistema.

Rápido, fácil y para toda la familia. Entre los aspectos negativos – ¿qué os creíais? Siempre hay un pero… – está la imposibilidad de actualizar la versión automáticamente cuando se produzca un nuevo lanzamiento. Si queremos disponer de futuras nuevas versiones será necesario volver a ejecutar el script. No obstante todo lo anterior, si no queremos complicaciones siempre podemos optar por usar Spotify desde el navegador, algo que hace ya bastantes meses que es posible e independiente del sistema operativo que usemos. Yo soy más tradicional, como os muestro en la captura:

 

Spotify openSUSE
Ya tenemos Spotify instalado en openSUSE

 

Espero que os sirva. Todo el crédito, por supuesto, para el autor del script y aquellos que lo precedieron, ya que se trata de un “fork” o bifurcación del programa original.

Fuente: https://github.com/cornguo/opensuse-spotify-installer

Salud y Geeko

49 comentarios en “Cómo instalar la última versión de Spotify en openSUSE”

    1. Yo, en cambio, lo utilizo mucho. En el móvil tiene el inconveniente de que no se pueden escuchar los temas en el orden que quieras, sino aleatoriamente, salvo que pases por caja, claro.

      Me gusta

  1. ¡Me alegro de que se haya simplificado! Lo que no me gusta de la nueva versión (1.0.x) es su nueva interfaz y, sobre todo, la imposibilidad de cerrar el programa en la bandeja del sistema. ¿Esto ha cambiado desde que lo probé? No veo el icono en tu bandeja del sistema y por eso lo comento.

    Siendo esto así, en Linux Mint, tengo instalada la versión 0.9.17 que me gusta más. Si la quieres descargar y convertir a .rpm (suponiendo que se pueda y funcione) lo puedes hacer desde aquí.

    Siento los problemas en Mint 17.3. En Mint 17 todo sigue bien.

    ¡Encantado de leerte de nuevo!

    Saludos,

    Me gusta

    1. Es cierto lo que comentas, en estas nuevas versiones ya no puedes minimizar la aplicación. No tengo ni idea de por qué. Con Linux Mint 17.3 tampoco sé qué pudo ocurrir, pero me da la sensación de que fue culpa mía, entre comillas, por abrir el equipo para limpiarlo. Al volver a conectar los cables, sobre todo de dispositivos USB, si no lo hago en un determinado lugar aparecen extraños comportamientos. Imagino que fue lo que pasó, porque sigo manteniendo Linux Mint 17.3 Mate en el portátil y no ha sucedido nada parecido.

      De hecho, con la nueva instalación de openSUSE tuve que mover la webcam de un puerto 3.0 a uno 2.0 para solucionar un extraño retardo al iniciar el sistema. Qué cosas.

      Me gusta

    1. Gracias por compartirlo. Se ve algo más complicado, como es natural, al tratarse de una tecnología que todavía esta en pañales como quien dice. Pero supongo que se irá simplificando con el paso del tiempo.

      Me gusta

  2. Más de una vez me he planteado instalar esta aplicación aunque nunca me había decidido. Gracias por la información. Por cierto, en dolphin tienes el terminal integrado con un simple “f4” y te aparece. Es una de sus ventajas entre otras muchas.
    Un saludo y gracias por escribir.

    Me gusta

    1. Lo cierto es que llevo casi todo el verano un poco desconectado del blog y de Linux, buscando descansar y recargar pilas. Aproveché para limpiar el ordenador, que falta le hacía, y al volver a conectarlo ya no me iban bien Linux Mint, Ubuntu o Antergos. Hace una semana probé con openSUSE y funcionaba bien, con solo cambiar la webcam de puerto no había retardos ni problemas raros. La respuesta a tu pregunta supongo que es que no tengo distro de cabecera, para qué nos vamos a engañar…

      Me gusta

      1. Me encuentro en una situación parecida. Desde mis inicios en Linux allá por el 2007 hasta hace cosa de un año he usado un montón de distros pero siempre tenía una que era mi referente, mi distro de cabecera (Mandriva de 2007 a 2011, y OpenSUSE de 2011 a 2015), pero no sé si será que me he ido volviendo más cómodo con los años, que empecé a ver cada vez más práctico lo fácil y sencillo que era todo en la familia Ubuntu, que no es que no lo fuera en las dos anteriores, pero Ubuntu va un paso más allá. De esa manera, mientras en los últimos años OpenSUSE había sido mi referencia indiscutible, a principios de 2015 ya veía a Kubuntu como otra gran referente, que traía lo mejor del universo Ubuntu con mi escritorio favorito (KDE), y a partir de entonces me ha sido imposible inclinarme completamente hacia una u otra, porque cada una tiene cosas de las que carece la otra. Y así estoy ahora mismo, que tengo claro cuales son ahora mismo mis dos referentes, pero sin poder inclinarme hacia completamente hacia ninguna de las dos. Aunque bueno, para los novatos en Linux, sobre todo por la mayor sencillez en la gestión de los repositorios, y no tener que priorizar entre unos y otros, tengo claro que es más sencillo ponerles a andar con Kubuntu que con OpenSUSE.

        Me gusta

      2. “Cada una tiene cosas de las que carece la otra”. La frase que resume mis años de experiencia en GNU/Linux de distribución en distribución. Y en mi caso añadiría los escritorios, con los que me pasa un poco lo mismo.

        Me gusta

      3. Yo con los escritorios lo tengo mucho más claro. He usado KDE, GNOME, Cinnamon, XFCE y LXDE, y hubo un tiempo en que la cosa para mí estuvo bastante pareja entre KDE y GNOME (2.32 por aquel entonces), pero con el tiempo las aplicaciones de KDE fueron ganando en funciones y en potencia, mientras que en GNOME empezaron a perderlas (a excepción del excelente File-Roller), así que me fui adaptando y acostumbrando cada vez más a las aplicaciones de KDE, hasta el punto de que a día de hoy, aún con las carencias que sigue arrastrando la nueva versión, no hay escritorio que le haga sombra a KDE.

        He intentado varias veces acostumbrarme al flujo de trabajo de GNOME Shell… y aunque no es complicado, para según qué cosas siguen haciendo falta más clics para cosas que en KDE hago con uno sólo. La personalización también me resulta más sencilla en KDE, y es más configurable. Quizás el que más se le acerque sea Cinnamon, que tiene un flujo de trabajo más parecido al de KDE y lo cierto es que también lo veo más sencillo de personalizar, aunque sea menos potente que GNOME, pero es más “out the box”.

        En conclusión, que ahora mismo no veo aplicaciones en otros escritorios a la altura de Dolphin, Okular, Kate o Kdenlive.

        Me gusta

      4. Claro, eso depende mucho de las aplicaciones que cada uno utiliza. Para mí, Dolphin es el mejor gestor de archivos. Kate me da un poco igual, porque no programo. Okular me gusta, pero tampoco le doy uso a sus opciones más avanzadas. Sin embargo, me gustaría una integración de KDE con las cuentas online (Google, ownCloud, etcétera) como la que a día de hoy ofrece Gnome. Y Kmail, mira que llevo años tratando de habituarme a su uso, pero es que no hay manera. Me sigue haciendo cosas raras, las mismas que hace un lustro, además de que lo noto lento en la sincronización.

        Me gusta

      5. Yo los clientes de correo hasta el momento los he eliminado de mi lista de aplicaciones a usar. He tirado siempre con webmail, al principio por espacio en disco, que no quería ocuparlos con mis miles de correos, y después por costumbre y también porque las características de Gmail (que es el que uso desde 2010, aunque últimamente he flirteado con ProtonMail) han ido potenciándose con el tiempo, así que no me planteo usar cliente de correo.

        En cuanto a la integración de KDE con servicios online, ciertamente estaría muy bien, y es probable que se vaya dando con el tiempo, pero en contrapartida tenemos esa maravilla que es KDE Connect de la que carece GNOME con la que podemos conectar el smartphone con el PC mejor con el propio cable.

        Me gusta

      6. Hubo una época en que yo tampoco usaba cliente de correo pero cuando descubrí openmailbox y lo empecé a compaginar con gmail le volví a encontrar utilidad. Poder contestar desde diferentes cuentas usando la misma interfaz, por ejemplo. En cuanto a KDE Connect, con decirte que lo instalo hasta en Ubuntu ya te lo digo todo. Herramienta tremendamente útil y que sigue mejorando.

        Me gusta

      7. Ése es un error que arrastra KDE desde hace tiempo en determinadas circunstancias. A mí a veces me ha sucedido y a veces no. Por desgracia nunca he sabido solucionarlo.

        Me gusta

      8. Chequen si esto les funciona:
        http://www.forosuse.org/forosuse/showthread.php?t=32573

        Ambas soluciones que estan en ese post del foro funcionan de mil maravillas con oS Leap 42.1.

        Aclaro que aunque yo hice el post, las soluciones no son de mi autoría sino una agrupación de varias páginas que consulte pero que desafortunadamente no he encontrado los enlaces originales para dar el crédito a quien lo merece.

        El post tiene dos guías:
        1. Ajuste de pulseaudio para evitar los cambios en el volumen del sistema.
        2. Ajuste de pulseaudio para que skype no interrumpa la reproducción de la música, por ejemplo.

        Espero que les sea de utilidad.

        Me gusta

  3. Gracias amigo. Estuve luchando un buen rato para poder instalar el maldito putifai. Personalmente me arreglo con mucho menos, pero para mis hijas parece que es imprescindible tener esta aplicación, cuestión de vida o muerte. Ya veremos como hago para pasarlas al “lado oscuro” y les instalo una aplicación similar opensuorce. Pude contra el gigante de micro$oft, no creo que este putifai sea rival…

    Me gusta

  4. Gracias Enrique Bravo por enseñar como instalar Spotify en OpenSUSE 42.2. He utilizado tus explicaciones y me han sido de gran utilidad. Y es que siempre hay que escuchar a los maestros, en este caso leer sus trabajos.

    Me gusta

    1. No tengo ni idea de qué puede haber fallado. Puedes probar a descargar de nuevo el script o hacerlo en un directorio o partición distintos, por si se debiese a problemas de permisos de escritura o a una descarga corrupta.

      Me gusta

  5. I’ve tried an another script in OpenSuse Leap 42.2, but this one didn’t works well and it was an old Spotify version.

    You provided a better script! This one works like a charm!

    Thanks!

    Me gusta

      1. Cuando intento hacer login, automaticamente se cierra la aplicacion, intento hacer login con FB e igual se cierra, uso open suse 42.2 en Kde plasma..que sera ??

        Me gusta

      2. A mi me pasa lo mismo que indica valeen.
        Despues de instalar spotify tal como se indica en este blog, justo despues de introducir el usuario y contraseña en la venta principal de spotify se cierra automaticamente.
        Lo he lanzado desde la konsola, y este es lo que muestra:

        javier@Phanton:~> spotify
        spotify: /lib64/libssl.so.1.0.0: no version information available (required by spotify)
        spotify: /lib64/libcrypto.so.1.0.0: no version information available (required by spotify)
        spotify: /usr/lib64/libcurl.so.4: no version information available (required by spotify)
        /usr/share/spotify/spotify: /lib64/libssl.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
        /usr/share/spotify/spotify: /lib64/libcrypto.so.1.0.0: no version information available (required by /usr/share/spotify/spotify)
        /usr/share/spotify/spotify: /usr/lib64/libcurl.so.4: no version information available (required by /usr/share/spotify/spotify)
        [0116/225600:ERROR:main_delegate.cc(752)] Could not load cef_extensions.pak

        (hasta esta linea es lo que muestra la consulta cuando aparece en pantalla el formulario de login en spotify, lo que pongo a continuación es lo que se muestra cuando introduzco el usuario, contraseña y doy a login)

        /proc/self/exe: /lib64/libssl.so.1.0.0: no version information available (required by /proc/self/exe)
        /proc/self/exe: /lib64/libcrypto.so.1.0.0: no version information available (required by /proc/self/exe)
        /proc/self/exe: /usr/lib64/libcurl.so.4: no version information available (required by /proc/self/exe)
        [0116/225600:ERROR:main_delegate.cc(752)] Could not load cef_extensions.pak
        [0116/225604:ERROR:PlatformKeyboardEvent.cpp(94)] Not implemented reached in static bool blink::PlatformKeyboardEvent::currentCapsLockState()
        Violación de segmento (`core’ generado)
        javier@Phanton:~>

        A ver si me podeis ayudar. Un saludo y gracias.

        Me gusta

      3. Es un error del propio Spotify que se reproduce en cualquier distribución. En Arch Linux, por ejemplo, ya lo han corregido. La única solución es esperar a que lo solucionen también para openSUSE y usar, entre tanto, la versión web.

        Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s