Solucionar error de actualización de Chrome en Linux Mint

Logos de Chrome y Linux Mint

Llevo varios días postergando un problema en mi equipo de escritorio con Linux Mint 17.3 Rosa Cinnamon que atañe al repositorio de actualizaciones de Google Chrome. No es que use demasiado el navegador de la gente de Mountain View, pero hay ciertas páginas que van regular con Firefox – oh, casualidad, Google Plus es una de ellas – y se me hace más cómodo verlas ahí. Como decía, resulta que desde que Google decidiera retirar el soporte de actualizaciones a su navegador para GNU/Linux en las arquitecturas de 32 bits, cada vez que Linux Mint refrescaba los repositorios aparecía el susodicho error, en forma de aspas rojas sobre el escudo de la barra de tareas, tal que así:

 

Error actualización Linux Mint
Algo no va bien con las actualizaciones

 

Ayer, los amigos de WebUpd8.org publicaban una solución que realmente funciona y de la que me voy a hacer eco. No temáis, que no es nada complicado de resolver.

Abrimos la terminal, bien la escogemos desde el menú de Linux Mint o usamos la combinación de teclas CTRL + ALT + T. Al gusto del consumidor. Escribimos en ella el código que sigue:

sudo gedit /etc/apt/sources.list.d/google-chrome.list

Introducimos nuestra contraseña y ya tenemos abierto el editor de texto en modo super-usuario. En lugar de gedit podemos usar pluma (el predeterminado en MATE) o incluso algún editor en consola, como nano o vi… bueno, si usas vi no estarás leyendo esto, casi seguro.

En el archivo a editar, buscamos la línea:

deb http://dl.google.com/linux/chrome/deb/ stable main

Y le añadimos la expresión [arch=amd64] para que quede de esta forma:

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

Quedando como se muestra en la imagen de abajo.

 

Gedit abierto en Linux Mint
La línea que hemos cambiado es la que está subrayada en azul

 

A continuación, guardamos y salimos del editor. De vuelta a la consola, abrimos un segundo fichero:

sudo gedit /opt/google/chrome/cron/google-chrome

Buscamos estas dos líneas:

REPOCONFIG="deb http://dl.google.com/linux/chrome/deb/ stable main"
SSLREPOCONFIG="deb https://dl.google.com/linux/chrome/deb/ stable main"

Volvemos a colocar la misma expresión, [arch=amd64], en cada una de ellas y tenemos las líneas corregidas:

REPOCONFIG="deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main"
SSLREPOCONFIG="deb [arch=amd64] https://dl.google.com/linux/chrome/deb/ stable main"

El resultado tiene que ser el que se muestra a continuación:

 

Editor Gedit en Linux Mint
Ídem en esta imagen: las líneas subrayadas han sido cambiadas para resolver el problema

 

Guardamos, salimos y… ¡eso es todo! Nos quedará abrir el gestor de actualizaciones y, usando el botón de “Refrescar”, hacerlo pasar de esta triste imagen:

 

Error al actualizar Linux Mint
Emoticono con cara contrariada… nada bueno

 

A esta otra, contento y feliz:

 

Linux Mint actualizado
Todo ha vuelto a la normalidad en nuestro Linux Mint

 

Hemos recuperado la paz y la armonía. Los agradecimientos a Andrew, de WebUpd8.org. Yo me he limitado a traducir y publicar su solución, que también es válida para Ubuntu, Debian y derivadas, al usar el mismo repositorio para Google Chrome.

Salud

Fuente: Fix `Failed To Fetch` Google Chrome Repository After Google Dropped Support For Its Browser On Linux 32bit

85 comentarios en “Solucionar error de actualización de Chrome en Linux Mint”

  1. Gracias por el aporte. Me ha servido para Ubuntu 14.04.4 LTS, aunque yo he venido actualizando, mas mal que bien, mediante dos comandos por separado. A saber: primero apt.get update y tras finalizar tirar apt-get upgrade.

    Me gusta

    1. De nada. Sí, yo también podía actualizar antes de aplicar la solución, era más bien un aviso y no un error. Pero en Mint, al menos, la solución sirve para devolver el gestor de actualizaciones a la normalidad.

      Me gusta

      1. Pues sí. La sensación de chapuza que da es tremenda, además de significar un paso más hacia el abandono al que se está condenando a muchos equipos de 32 bits dentro del mundo GNU/Linux. Por suerte, la mayoría de distribuciones y programas se siguen ofertando para esa arquitectura.

        Me gusta

  2. Mi laptop es de 32 bits, por lo tanto Linux Mint también y, obvio, Chrome también.
    ¿Es correcto en mi caso seguir estos pasos?
    No lo he hecho por miedo a dejarlo peor
    Siento que en breve me quedaré sin Chrome y sin poder ver Netflix (que para eso lo tengo instalado)

    Me gusta

    1. No, Six, me temo que no. El soporte de Chrome para 32 bits ha sido retirado, de manera que no recibirás actualizaciones de ningún tipo, ni siquiera de seguridad. Mi consejo es que te pases a su alternativa libre, Chromium, o cualquier otro navegador que soporte Netflix. En ese tema no te puedo ayudar, no uso esa plataforma.

      Me gusta

      1. Vivo en el cromañón de los bits, qué lástima.
        Chomium no esta preparado para Netflix, espero que en elguna actualización empiece a tener soporte para reproducción de vídeo html5.
        Gracias Enrique!

        Me gusta

  3. Otro problema resuelto gracias a tu fabulo blog. Cuánto he echado de menos tus frecuentes post desde que te volcaste en tu oposición. El mejor blog para los usuarios modestos de Linux. No nos dejes

    Me gusta

  4. Off-topic: ¿Algún problema con el sistema de caché del blog? Leí este mismo artículo ayer (vía RSS) y hoy seguía sin salirme en la página principal hasta que he hecho Control + F5. Lo mismo con los contadores de comentarios.

    Me gusta

    1. Llevo unos cuantos días comiéndome el coco con este tema, Juan. A ver si doy con la solución o me veré obligado a prescindir del “plugin” WP Super Caché. Sería una lástima porque ha mejorado mucho la rapidez de carga del blog, pero algo estoy haciendo mal en la configuración que provoca ese comportamiento anómalo. ¡Gracias por avisar!

      Me gusta

      1. Muchas gracias por la sugerencia. Funciona genial y se acabó el problema que tenía con la caché en Google Chrome 🙂

        Me gusta

  5. Sólo comentar que yo he tenido que modificar el fichero /etc/apt/sources.list.d/google-chrome-stable.list en vez de sudo gedit /etc/apt/sources.list.d/google-chrome.list para que me funcione.

    Me gusta

  6. Gracias por la solución, el 3/3 me salio el error al actualizar desde terminal, y ayer 4/3 apareció una actualización desde el actualizador gráfico, pero el error en la terminal seguía, ya con esto quedo listo y se vuelve a ver “bonito” mi sistema!!
    Saludos!

    Me gusta

  7. Gracias de parte de mi mujer 🙂
    Hace pocos días le instalé Mint porque Ubuntu le iba lentísimo. Todavía no había acabado yo de asegurarle que los problemas en Mint ocurren una vez cada milenio (a mí cuando lo usaba, nunca me dio ni medio problema), cuando en poquísimo tiempo ha habido dos incidencias una grave, el ataque al sitio, y la otra molesta, esta de la que nos has dado la solución.
    Esperemos que Mint vuelva a aburrirnos como en su mejores tradiciones.

    Me gusta

  8. fantastico!! un ckrack. Perfecto en kubuntu 15.10
    Pero esto se solucionara por si solo, en alguna update….16.04 LTS que tengo pensado quedarme ahi y virtualizar lo demas.

    Me gusta

  9. Gracias a todos los que hicieron posible este artículo. Odio ver mensajes de advertencia en las actualizaciones y con esto todo vuelve a la normalidad.

    Me gusta

    1. Me dejas en fuera de juego. De todos modos, no pasa nada por añadir esa línea, se trata de habilitar la conexión en modo seguro al repositorio de Google. Me resulta extraño que no existiera de antemano, pues se supone que se añade automáticamente al instalar Google Chrome por primera vez desde la página de Google.

      Me gusta

      1. Pues no sé, la he añadido ahora y la actualización de la lista de paquetes no da error.

        No obstante, te diré que la línea:

        REPOCONFIG=”deb [arch=amd64] http://dl.google.com/linux/chrome/deb/

        Ya estaba tenía el texto [arch=amd64] y que, además, bajo esta, había (y siugue habiendo, porque no la borré) otra línea con el texto:

        REPOCONFIGREGEX=”deb ([arch=[^]]*bamd64b[^]]*][[:space:]]*)?https?://dl.google.com/linux/chrome/deb/ stable main”

        Dicho lo cual, añado, le había aplicado hace unos días esa otra solución que circuló por ahí pero que no era persistente, y que consistía en aplicar el comando:

        sudo sed -i -e ‘s/deb http/deb [arch=amd64] http/’ “/etc/apt/sources.list.d/google-chrome.list”

        Igual la cosa tiene que ver con esto.

        Saludos.

        Me gusta

      2. Debe ser cosa de la otra solución entonces. La que puse aquí sí es persistente. Esta semana se actualizó Chrome y no hubo problemas.

        Me gusta

  10. Hola primeramente quiero agradecer por el gran trabajo de muchos años a linux mit, sinceramente para mi es muy buen sistema nunca me fallo ,auque antes tenia big linux y lo adoraba ya hace como 5 q me enamore de mint gracias hora a probar 13.3 rosa .

    Me gusta

  11. hola la solusion es facil solo tenemos que ir a “software Sources” y en Additional Repositories. Borrar el repocitorio de Google crome y solucionado el problema: no aparesera mas el error y podemos seguir actualisando el: tips el problema susede cuando enpiesa a buscar actualisaciones y no encuentra el de google crome y sale el error: borrando el repocitorio de google crome se soluciona asi la maquina no buscara mas la actualisacion de google

    Me gusta

      1. Me salió todo bien hasta que llegué a ésta parte: “De vuelta a la consola, abrimos un segundo fichero:

        sudo gedit /opt/google/chrome/cron/google-chrome

        Buscamos estas dos líneas:

        REPOCONFIG=”deb http://dl.google.com/linux/chrome/deb/ stable main”
        SSLREPOCONFIG=”deb https://dl.google.com/linux/chrome/deb/ stable main”

        El segundo fichero que logré abrir estaba en blanco. No estaban ésas dos líneas. No sé qué error tonto estoy cometiendo.

        Me gusta

    1. Siento no tener la solución a tu problema. No entiendo por qué ese fichero está vacío en tu caso y no en el mío. Podrías probar a preguntar en los foros de Linux Mint.

      Me gusta

      1. Sr. Bravo, Ud. es muy amable al dedicar parte de su tiempo y de su trabajo en tratar de ayudarnos. Pero no siempre se encuentra gente como Ud.. Verá, yo soy un simple usuario común. No soy especialista en nada. En los foros, he intentado preguntar, pero no todas las personas tienen la amabilidad que tiene Ud.. Directamente no responden, o a uno lo tratan de “luser”, un eufemismo que en inglés combina la palabra “user” (usuario) con “loser” (perdedor). Lo tratan de usuario perdedor, con el que ni siquiera vale la pena perder el tiempo. Hay mucha soberbia, mucha arrogancia y mucho desprecio en los foros. He intentado realizar un curso de aprendizaje de Linux acá, en Montevideo, que es una ciudad que tiene más de 1.000.000 de habitantes. Y no hay ni siquiera 10 interesados en aprender Linux. Por eso el curso no se inicia. No hay nadie para aprender, entonces no hay nadie para enseñar. He tratado de revolver todo lo que he podido en internet, pero no siempre se encuentran buenos artículos como éste. Uno trata de aprender como puede, pero hasta ahora son más los revolcones. Eso es muy frustrante. Me he cansado de intentar y fallar, de preguntar y recibir indiferencia o desprecio. Estoy seriamente evaluando regresar a Windows. Por lo menos Windows, está diseñado para el usuario común, no para el experto. En Windows los usuarios comunes no tenemos que andar haciendo preguntas, y si surge la necesidad, otro usuario común, sin soberbia puede respondernos. Hace falta mucha gente como Ud. en Linux, mucha. Créame que le estoy sinceramente agradecido y reconocido y lo felicito. Cargaré con una frustración más, y evaluaré todos estos meses transcurridos. Vayan mis atentos saludos para Ud..

        Me gusta

      2. Hola JBJB:

        Siento que tu experiencia en algunos foros haya sido frustrante.

        Para poder intentar ayudarte es importante que primero comentes qué distribución, versión de la misma y escritorio usas para poder hacer pruebas y encontrar donde está el fallo.

        Si tu distro (como apunta Enrique) es Linux Mint, te invito a que participes en el Foro de Linux Mint en castellano (https://forums.linuxmint.com/viewforum.php?f=68) en donde creo que encontrarás respuesta y no frustración.

        Saludos,

        Me gusta

      3. Su comentario me produce mucha tristeza. Creo que se ha topado con la parte más desagradable de Linux: los errores (éste en cuestión es responsabilidad de Google) y los usuarios arrogantes. No me creerá, pero son minoría en realidad, lo que pasa es que hacen mucho ruido.

        Ánimo y tampoco pasa nada por usar lo que mejor nos funcione. Si es Windows, pues Windows. No hay que darle más importancia.

        Un saludo

        Me gusta

  12. Algo ha cambiado en los últimos meses. Acabo de probar en una instalación limpia de Linux Mint 17 (Mate) instalar Google Chrome (la única opción disponible para descargar es la de 64 bits) y ya no hay ningún problema que arreglar. Se instala normal, funciona normal y no hay ningún error en el Gestor de Actualizaciones. 🙂

    Me gusta

    1. Pues bien por Google que, aunque ha tardado, finalmente ha arreglado el entuerto. Por desgracia aún hay usuarios con problemas, como el que nos escribe más arriba, a quienes la falta de soluciones les lleva a desistir de seguir en GNU/Linux.

      Me gusta

      1. Hay un comentario mio de esta tarde que se ha perdido por el camino. En él, le proponía a JBJB que informara de qué distro, versión y escritorio utiliza para poder hacer una prueba e intentar ayudarle.

        También le invitaba a participar en el Foro de Linux Mint en castellano (según indicas, Enrique, es la distro que utiliza): https://forums.linuxmint.com/viewforum.php?f=68 donde estoy seguro de que recibirá respuestas y no frustraciones.

        Me gusta

      2. Ya se ve tu comentario, Juan Carlos. Akismet suele enviar a “pendientes” los comentarios con enlaces externos. Arreglado.

        Me gusta

    1. Los comandos son los mismos, Alexis. Google tiene un repositorio único para distribuciones que usan paquetes “.deb” (Debian y derivadas, como Linux Mint) y otro para las que usan “.rpm”. En este caso, aunque no siempre, lo que vale para Linux Mint también vale para Debian.

      Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s